Let's follow up this discussion at the Neptune Community

(this forum will be kept in read-only mode)

Java Script Error while developing SAP UI5 based applications

Hi ,

 

I am getting the below error when running any application, even the application provided by Neptune. I have already configured the settings.

 

sapui5/resources/sap-ui-core.js. But how to make this is the correct path?


Error

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET CLR 1.1.4322; .NET4.0C; .NET4.0E; InfoPath.3; MS-RTC LM 8)
Timestamp: Fri, 30 Aug 2013 16:14:21 UTC


Message: Script error
Line: 0
Char: 0
Code: 0
URI: https://sapui5.netweaver.ondemand.com/resources/sap-ui-core.js


Message: 'sap.m.App' is null or not an object
Line: 18
Char: 2
Code: 0
URI: http://edcmsz01.lyondell.com:9200/neptune/NAD_UI5_GOPI_SAMPLE?sap-ui-xx-fakeOS=ios


Message: Unexpected call to method or property access.
Line: 4
Char: 26196
Code: 0
URI: http://edcmsz01.lyondell.com:9200/neptune/server/jquery/js/jquery-1.9.1.min.js

 


Hi Gopi


Settings

As of default the setttings regarding SAPUI5 path is empty. Then the ondemand library will be used.

https://sapui5.netweaver.ondemand.com/resources/sap-ui-core.js


If you install SAPUI5 locally, you can override the path with the settings.


Browser

Could you try the application with Chrome and see if that helps ? For a full overview of supported browser, please check this link:

https://sapui5.netweaver.ondemand.com/sdk/#docs/guide/BrowserSupport.html


Library

When creating an SAPUI5 application, you only need to select the corresponding SAPUI5 library and theme.





Thank you Gopi for your feedback.


Problem was the browser - version/mode.


For SAPUI5 browser and mobile support, please look at this link:

https://sapui5.netweaver.ondemand.com/sdk/#docs/guide/BrowserSupport.html

Login or Signup to post a comment