Let's follow up this discussion at the Neptune Community

(this forum will be kept in read-only mode)
Solved

Missing class Interface /NEPTUNE/IF_NAD_SERVER

Dear Friends,


We get the message "Missing class Interface /NEPTUNE/IF_NAD_SERVER".


I just copied one on one from one class to another and changed the applications class in the settings. The Interface /NEPTUNE/IF_NAD_SERVER still exists in the class. 


Thank you for your support.

regards, 

Daniel


Hi Daniel,


we had this problem before with inactive classes. Usually it helps to just close and reenter NAD and activate again. Please also try to open your class in codebase mode and activate.


Can you also check the other settings for the application class? Superclass, instantiation etc.? Must be some missing or settings in the application class that generates this error.


Best regards

Christoph

Hi Christoph,


thanks, it works now. I tried it serveral times, but always get the message.


regards,

Daniel

I know this is an old topic now, but I just wanted to add, I have just had this problem, and my solution was to go out of Neptune (which means the class doesn't get saved to the app) then go back in again and add it.  Some sort of caching if you add the class, then add the interface.


Regards,

Gary

Hi Gary,


thanks for your feedback - much appreciated!


By the way - are you attending Neptune Summit 2017? You should - check out the agenda neptune-software.com/summit :)


Best

Christoph

Login or Signup to post a comment