Let's follow up this discussion at the Neptune Community

(this forum will be kept in read-only mode)

Neptune UXP 4.0, Hybrid-App and common namespace sap.n

Dear Neptune team,


the new functionality to switch between apps (by split and by switch with "AppCache.Load("APP_NAME", {dialogShow: true, dialogTitle: "App_Title"});" and to use the common namespace "sap.n" for sharing data between apps, works fine for the "Desktop Launchpad" (Browser).  


But when I try that in the hybrid app "Mobile Launchpad" via Neptune Client on the iPhone, it is only possible to switch the app with "AppCache.Load(...)" but the common namespace "sap.n" is not defined and therefore it is not possible to share data between 2 apps in a hybrid app (e.g. for one central app --> display customer master data) and therefore also the state of each app is not stable.


Do you know another solution for that request?


Best regards

Jürgen


Hi Jürgen


If you are using our Neptune Client from the App Store, it is still running on old AppCache framework. The new Neptune Client will be available in the beginning of April.


Or are you using your own client built in NAM ? Then you need to have the NEPTUNE_LAUNCHPAD_MOBILE as the default in NAM.


And the split view is only working for desktop. No space to do this on mobile devices.


Regards

Ole Andre 

Hi Ole-Andre,


I tried for our test your Neptune Client from the App Store with the link to our sandbox system (UXP 4.0), so probably that is the answer. Our own productive client was also build with the old framework.

In the NAM I already assigned the correct new Launchpad "NEPTUNE_LAUNCHPAD_MOBILE" in a new test Bundle from our sandbox environment and that bundle I linked in the Neptune Client. The split is clear (I checked that already with 2 different bundles (desktop and mobile) --> thank you).

So we will try to build our own client once again in the UXP 4.0 environment, if that should be the solution.


Do you agree?


Regards

Jürgen

Hi Jürgen


Yes, if you now update your own client it will work. Remember to also update the phonegap version. I would suggest you try cli-6.0.0.


Regards

Ole Andre 


Login or Signup to post a comment